KB Article | Forcepoint Support

Problem Description

Forcepoint User ID (FUID) server versions up to 1.2 have a remote arbitrary file upload vulnerability on TCP port 5001. Successful exploitation of this vulnerability may lead to remote code execution.

Forcepoint has reserved CVE-2019-6139 to identify and track this issue with an assigned CVSSv3 Base Score of 9.8 (Critical) [CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H]

Resolution

To fix this vulnerability, upgrade to FUID version 1.3 or higher.

To prevent the vulnerability on FUID versions 1.2 and below, apply local firewall rules on the FUID server to disable all external access to port TCP/5001. FUID requires this port only for local connections through the loopback interface.

We also strongly recommend applying additional local firewall rules on the FUID server as recommended in KB16537.
 

Article Feedback



Thank you for the feedback and comments.