KB Article | Forcepoint Support

Problem Description

Customers receive the message "Stronger security is required" in their web browser (Internet Explorer, Google Chrome, Firefox, or Safari).

Resolution

This message indicates that the user is trying to access a website that requires TLS 1.1 or higher, but the user's browser either does not support TLS 1.1 or is not correctly configured to use it. 

In all cases, the solution is for the user to upgrade their web browser or switch to another browser that supports TLS 1.1 or higher. For Internet Explorer users, the article "Enabling TLS 1.1 and TLS 1.2 in Internet Explorer" may be helpful for setting connection options correctly.

Article Feedback



Thank you for the feedback and comments.